ADVANCED CABLE CREATOR MANUAL

version 1.0
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INSTALLATION

1. Import ACC to your project from the Asset Store or Package Manager.

2. Once Unity show a list of files just click .

3. Wait until Unity complies the scripts.

4. For URP/HDRP, simply extract the appropriate package from the tool root folder.

Now you can start using ACC.

QUICKSTART

1. Create a new Cable Trail object by selecting GameObject > NOT_Lonely > Cable
Trail in the main menu or click the right mouse button in the Hierarchy window and
select NOT_Lonely > Cable Trail.

GameObject Component Tools Tutorial Window  Help

Create Emnpty Ctrl+5Shift+M
Create Empty Child Alt+5Shift+ M
Create Empty Parent

3D Object »
Effects >
Light »
Audio *
Video ¥
Ul »
Volume *
Camera

Scene Variables

Convert To FBX Prefab Variant...
Export To FEX...
Export Selected Timeline Clip...

Center On Children

Malke Parent

Clear Parent

MOT_Lonely * Cable Trail
et as first sibling Ctrl+=
Set as last sibling Ctrl+-
Move To View Ctrl+Alt+F
Align With View Ctrl+Shift+F

Align View to Selected

Toggle Active State Alt+5Shift+A

2. A Cable Trail object will appear in the scene straight forward to the scene view
camera.



3. To change the cable length and position you can use two different ways:
a) move the control point handles in the scene view

A Cable Trail controlled by scene view position handles.

b) drop some scene objects into the External Control Points list and then press
the button below to apply changes.

able Trall . :
External Control Points

Listis Empty

Update

Dropping scene game objects into the External Control Points list.

A Cable Trail controlled by two cubes.

4. Add an extra cable trail section by clicking the FAGCERNETALENRSEE ) button at
the bottom of the Cable Trail inspector.

5. Cable trail section can be removed by selecting one of the Cables in this section
and pressing the Delete key on the keyboard.



CABLE TRAIL SETTINGS

CoNTROL POINTS

Offset

It's an offset vector that adds to the positions of the Cable Trail control points. It can be
used in a case when you want to create a cable between several objects, set in the
External Control Points list, but the cable mesh have to be moved off the objects pivots.

Offset is set to 0 by all axis. Offset is set to 2 by Y axis.

External Control Points
Array of transforms that used as control points. Drop at least two scene transforms here.

External Control Points

List is Empty

Cable Trail will use the order of this array elements for its sequence. Elements of the
array can be reordered.

Element0 M Cylinder (Transform) @ Element 0 A Cylinder (Transform)
Element1 M Cube ( sform) = Element1 A Sphere (Transform)

Element 2 M Sphere (Transform) & Element 2 .. Cube (Transform)

If you added, removed or reordered elements in this array, press the button to
apply changes.



External Control Points

Element O A Cylinder (Transform)

Element 1 A Cube (Transform)

Element 2 M Sphere (Transform)

Update
3

TRAIL

Amount
The number of Cable Sequences (parallel cables) in the Cable Trail.
Use these two buttons to change this parameter.

TRAIL

Amount

Step Size

Distances between Cable Sequences in their local X, Y and Z axes.

Position Randomness
Randomizes the X, Y and Z positions of the parallel cables. When values above 0 are used,
Step Size values become maximum step distances in the random range.

Step Size X = 0.3 Step Size Y=0.3 Step Size Xand Y = 0.3
Position Randomness X =1 Position Randomness Y =1 Position Randomness Xand Y =1



MESH

Radial Segments
Cross section segments of each generated cable mesh. A minimum value is 2.

A two-sided shader is used on the images below for demonstration purposes.

Radial Segments = 2 Radial Segments = 4 Radial Segments = 6

Angle
A normalized angle of the cross section, where 0 = 0 degrees, 1= 360 degrees. Useful to
rotate the mesh cross section when using only 2 Radial Segments.

Angle =0 Angle = 0.75 (270 degrees)



Length Segments

Lengthwise segments number of each half of cable. Set more Length Segments for very
sagging cables to avoid angularity mesh look.

Length Segments = 4 Length Segments =10



Invert
Inverts the mesh so you will see its back side instead of front side. Can be useful when
you set Radial Segments = 2 and want to flip the visible side of the mesh.

Vertex Alpha Brightness

ACC generates a two-sided gradient in the vertices alpha, which can be used for a vertex
animation on a shader side to control the amplitude of the vertex motion. If the Cable
Trail consists of more than one cable by its length, the gradient brightness for each cable
will depend on the length of this cable, where the longest cable will have the most bright
vertex alpha.

The Vertex Alpha Brightness parameter multiplies the alpha gradient and can be adjusted
between different Cable Trails, to make it able to use the same material on all the cables,
but have a different vertex amplitude. It's good for performance. This value range is 0-1.

A debug vertex alpha shader is used on the images below for demonstration purposes.

Vertex Alpha Brightness =1 Vertex Alpha Brightness = 0.3

Texture Tiling Multiplier

Mesh UVs generate and adopt automatically to the proportions of the main color texture
from the applied material.

The main texture property name in the shader must be “_MainTex” to make it work.
Optionally, you can use the [MainTexture] attribute with any other property name.

Using this Texture Tiling Multiplier parameter you can stretch or squeeze the generated
mesh UVs along the cable. 1= use original texture proportions, less than 1 = stretched
texture, greater than 1= squeezed texture.

Texture Offset Randomness
Randomizes the texture offsets between each Cable Sequence. The value is in 0-1range,
where 0 means no random, 1 - maximum random. Setting this value greater than 0 will



help to make a more natural look of the parallel cables in the Cable Trail.

A pennants texture is used on the images below as a more illustrative example.

Texture Offset Randomness =0 Texture Offset Randomness =1

UVs Angle

Defines the rotation of the generated UVs. The UVs orientation calculates automatically
when you assign a material to the cable, but you can add an additional angle to the
generated UVs using this parameter. This parameter only affects cables which use a
square texture in their materials. Keep in mind that there will be a visible seam when
used angles except 0, 90, 180, 270.
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UVs angle =0 UVs angle = 45 UVs angle = 90

Texture Twist min/max

This is the value that offsets every cable ring UVs to create a diagonal UVs layout. This
leads to the twisted-like texture mapping on the cable that makes it look like a twisted
cables.

The top cable Texture Twist = 0, the bottom cable Texture Twist = 1.



Materials

The materials array to apply to the meshes in the Cable Trail. A random material from
this array will be applied to each Cable Sequence. If this slot is empty, then a default
material with a default shader will be set.

SHAPE

Height Scale min/max
The minimum and maximum amount of the cable sagging. Use different values for the
'X'(min) and 'Y'(max) to randomize the sagging between the cables in the Cable Trail.

Height Scale min = 0.1, max = 0.1

Height Scale min = 0.1, max = 0.5




Length Dependency
This is the ratio of the cable section sagging to its length. So the longer the cable is, the
more sagging will add to it. If set to 0, all the cables will be affected by Height Scale only.

Thickness min/max
The thickness of the generated cables. Use different values for the 'X'(min) and 'Y'(max) to
randomize the parallel cables thickness.

Thickness min = 0.05, max = 0.15

Horizontal Curvature

ACC adds some additional curvature to the both ends of each cable Section in the Cable
Trail to get rid of sharp joints between the cables when the Cable Trail is twisty. The
amount of curvature on the joints in the horizontal plane can be adjusted by the
Horizontal Curvature parameter. Values less or equal 1 are optimal.

Horizontal Curvature = 0 Horizontal Curvature =1

Vertical Curvature
The same as Horizontal Curvature, but works in the vertical plane.




Vertical Curvature =0

Vertical Curvature =1

Noise

Amount of position randomness applied to the cable vertices.

Settings this value greater than 0 can help to achieve a more crumpled cable look. It's
useful for the corrugated loose cable trails.
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Some Noise applied to accentuate the loose cables look.

JOINTS

Joint Object

Put a prefab from the Project folder here. This object will be placed on the cable joints.

If you have an object already set in this field and want to change it with another one, just
put another object here and press the button to the right of the field.

Rotation
Joint objects automatically follow the cable path curvature, but sometimes you may need
to change their orientation. You can do that with the Rotation parameter.
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The Rotation parameter is set to 90 for the Z axis, so the Joint Objects are aligned correctly with the wall.

Use Uniform Scale
Joint object scale is locked to the cable Thickness, but can be multiplied by Scale
parameter. If Use Uniform Scale enabled, Scale will be locked between all axes.

Scale

A scale multiplier for the Joint Objects.

The final scale = Joint Object transform scale * cable Thickness * Scale.

Due this it's better to make the initial size of your Joint Object inner part (this one where
a cable goes through) =1 unit.

You can do this in a 3D-modeling program or simply parent your joint model to an empty
object with a transform scale =1, and scale the joint up so the inner part size of it is
equal 1 unit.




PREFAB PROPAGATION

Prefabs
Put prefabs from the Project folder to spawn them along the cable.

Selection Mode

This is a mode, which will be used to pick the prefabs from the array, when spawning
them. There are two available modes: Sequential - prefabs will be created in the same
order in which they are presented in the Prefabs array. Random - prefabs will be created
in a random order.

Amount
The number of the prefab instances that will be spawned along the cable.

Update
The button is required when you have changed the Prefabs array or the Amount
value.

Vertical Offset
The amount of offset along the Y axis, applied to the spawned objects. Useful if your
objects have wrong pivot point positions.

Start/End Offset

The position offsets applied to the first and the last spawned objects to shrink them
closer to the center of the cable.

Longitudinal Random
Follow path curve. 0 - no modification applied to the objects rotation, 1 - objects rotation
follows the cable curve.

Follow Path

The position randomness along the cable applied to the spawned objects.

Rotation Min/Max

The minimum and maximum objects rotations.

Scale Min/Max

The minimum and maximum scale of the objects. Use different values for the sides of the
slider to randomize the scale between these values, or set them to the same value to
make a scale constant.

OPTIMIZATION

All options in this section will be applied to the combined mesh on the Jeelyylol =R
button press.



Generate Lightmap UVs
If checked then a second UV channel will be generated for the lightmapping. Disable this
option if you don't plan to bake the lighting for this cable.

Backside

If Radial Segments set to 2, you can enable this ckeckbox to generate a backside of the
cable mesh. It's useful if you don't want to use a double-sided shader.

Save Path

A project relative path to save the combined meshes. It sets to the ACC folder by default.
To make it work properly, this path must start with Assets/.

Combine Meshes

Pressing this button will combine all the cable and joint meshes into a single mesh.

Once used this button the original Cable Trail object will be hidden and a combined object
will appear in the scene on its place. This will allow you to bake a lighting on the cables,
and decrease the CPU overhead that spends on Unity's batching.

EbITOR PERFORMANCE

Show Meshes

Disable this checkbox if you have a low FPS count, when editing the Cable Trail. If
disabled, then you will see the cable gizmos instead of the actual cable meshes.
Make sure that the Gizmos toggle is enabled in the Scene View.

CABLE SEQUENCE

Cable Sequences are the parts of the Cable Trail, and represent the parallel cables.

One of the four Cable Sequences is marked in red at this screenshot.



You can select any Cable Sequence in the Cable Trail hierarchy to override some settings
for this sequence.

For instance, this can be helpful, when you need a certain Cable Sequence to have a
certain sagging, while other sequences will use the Cable Trail settings.

To do that, you need to select the required Cable Sequence, check the Shape checkbox in
its settings to enable the override mode for this group of parameters and adjust the
Height Scale property. If any group of settings is overridden, the sequence object name
will have the “(Overrides are used)” text in it.

The most of parameters available for overriding in this manner.

The Cable Trail Height Scale set to 0.1, the red Cable Sequence Height Scale set to 0.3
CABLE

Cables are the parts of the Cable Sequences and represent the individual cable sections.
The Cable settings can be overridden in the same way as the Cable Sequence settings
(look the Cable Sequence chapter above).

One of the three Cables in the Cable Sequence is marked in red and has some properties overridden.

UTILITIES

Update All Cables

When you moved some External Control Points objects in your scene and want to update
all your Cable Trails at once, you can go to the main menu and choose: Tools >
NOT_Lonely > Advanced Cable Creator > Update All Cables.



This action is the same as the button press in the Cable Trail Ul, but for all the
Cable Trails in the scene at once.

Cable Combiner

You can combine multiple Cable Trails into a single mesh using this utility. It can be found
at Tools > NOT_Lonely > Advanced Cable Creator > Cable Combiner.

This utility repeats the functionality of the Optimization section in the Cable Trail Ul, but
it's not constrained to work for selected Cable Trail only.

To use it, just drop any number of Cable Trails into the Cable Trails list, adjust the
combining settings and press the Combine button.

The most up-to-date manual can be found here:
https://not-lonely.com/upload/acc/AdvancedCableCreatorManual.pdf

If you still have any questions, please contact: support@not-lonely.com


https://not-lonely.com/upload/acc/AdvancedCableCreatorManual.pdf
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